Issues with Tricefy App Login
Incident
03/13/2024, 10:33am EDT
Issues with Tricefy App Login
Status: closed
Start:
03/13/2024, 10:27am EDT
End:
03/13/2024, 10:33am EDT
Duration: 5 minutes
Affected Components:
Tricefy Web Application
Update
03/13/2024, 10:27am EDT
03/13/2024, 10:27am EDT
We are aware of problems logging into the Tricefy web portal and are working quickly to resolve.
This issue does not affect the ability to upload studies from your imaging devices or send images to patients.
Resolved
03/13/2024, 10:33am EDT
03/13/2024, 10:33am EDT
The issue is now resolved and the Tricefy web portal should be accessible again.