Tricefy Performance Issues

Incident
08/15/2023, 5:11pm EDT

Tricefy Performance Issues

Status: closed
Start: 07/26/2023, 2:07pm EDT
End: 08/15/2023, 5:11pm EDT
Duration: 20 days 3 hours 3 minutes
Affected Components:
Receiving Tier Tricefy Web Application
Update

07/26/2023, 2:07pm EDT

07/26/2023, 2:07pm EDT

We are currently experiencing instances of system slowness within Tricefy. This is impacting image uploads and image viewing within the Tricefy web portal. Our engineering team is attempting to isolate the root cause at this time. We apologize for the inconvenience and will provide updates when available.

Update

08/02/2023, 1:34pm EDT

08/02/2023, 1:34pm EDT

The Trice team is still actively identifying areas which may be causing the Tricefy web portal to load slowly. There are some improvements currently being made which will be released as soon as possible.

Resolved

08/15/2023, 5:11pm EDT

08/15/2023, 5:11pm EDT

The Tricefy 4.2.7 release last week helped address some of the more pressing Tricefy performance issues. The Trice team has seen an improvement in overall load times across the system -- we have also received reports of improvements from direct customer feedback.

There are some other smaller improvements we will be continuing to roll out in future releases. As always, please reach out to support@triceimaging.com for any feedback or issues. Thanks!